Verint WFM RTA 統合をトラブルシューティングします。


コネクターは、プログラムの実行で起きたすべてのイベントを記録する標準ログ ファイルを含みます。これらのファイルでは追跡と診断が可能です。

コネクターのログ ファイルには 2 つのタイプがあります。

  • ininbridgehost_{X}: これらのログ ファイルは、Bridge サーバーがコネクターを読み込んだときに作成されます。
  • {connector group name}_{X}.ininlog: これらのログ ファイルは、コネクターと設定の読み込みからの両方の追跡、およびコネクターによってログされた追跡を含みます。これらのログ ファイルは毎日作成され、また、コネクターが再起動するたびに作成されます。

これらのログ ファイルのコピーについては、次の手順に従います:

  1. [コネクターの詳細] ページに進みます。
    • At the top of the Admin page, click Admin > Integrations.
    • Bridge ページで、[コネクター] タブをクリックします。
    • 閲覧したいログ ファイルのコネクターをクリックします。
  2. [インスタンス] セクションで、[ログ] をクリックします。
  3. クリックします。 コネクタのログを要求します。.
  4. ダウンロードするファイルをクリックします。

ダウンロードした zip ファイルに両方のタイプのコネクター ログ ファイルが含まれています。

The Bridge Server includes its own logging system for logging information about the internals of the server. These log files contain low-level process details that can describe any problems with starting the server as a whole or with receiving messages. For example, if the Windows processes of the server do not start or there are no relevant traces in the connector log files, check the Bridge Server log files.

サーバーのログ ファイルの 4 つのタイプがあります。

  • ininbridgeprocesslauncher.ininlog: these log files record information about Bridge Server processes, suchas crashes and restarts.
  • ininbridgeserver_{X}.ininlog: これらのログ ファイルは、コネクターおよびそのプロセスの管理についての情報を含みます。
  • ininbridgeservices_{X}.ininlog: これらのログ ファイルは、Bridge サーバーと Amazon Web サービス間の通信についての情報を含みます。
  • ininupdate_ {×} .ininlog: これらのログ ファイルをブリッジ サーバーをシャット ダウンする、新しい更新プログラム パッケージをインストールして、再起動に関する情報を記録します。

これらのログ ファイルのコピーについては、次の手順に従います:

  1. [サーバーの詳細] ページに進みます。
    1. At the top of the Admin page, click Admin > Integrations.
    2. On the Bridge page, click the Servers tab.
    3. Click the server whose log files you want to view.
  2. [ログ] をクリックします。
  3. [サーバーのログをリクエスト] をクリックします。
  4. ダウンロードするファイルをクリックします。

問題

プロキシ サーバーを使用すると、いくつかの分後ブリッジ サーバーが切断されます。

原因

ブリッジ サーバーは、PureCloud との双方向通信用長寿命安全な WebSocket 接続を使用します。

ソリューション

長寿命、非アイドル状態の接続を許可する web プロキシを構成します。

問題

コネクターの起動に失敗しました。

原因

コネクターの失敗には、次のような理由が考えられます。

  • プロキシ サーバーの設定が正しくありません。
  • 他の予期されないエラーが発生した。

ソリューション

  • 設定し、構成されていることを確認、 プロキシ サーバー 正しく。
  • コネクタ ログ ファイルでエラーに関する情報を確認します。 

問題

WFM ソフトウェアでは、エージェントのステータスが表示されません。

原因

エージェントのステータスは、いくつかの理由があります。

  • エージェントは、監視するキューには含まれません。
  • エージェントの一部であるキューが監視されていません。 
  • 統合は、エージェントの特定の存在を無視しています。 
    メモ: のみの統合はキューに、キューをオフなど ACD プレゼンスをコネクタ構成の [状態コードにマップします。

ソリューション

  • エージェントを監視されているキューに追加します。
  • 監視するキューのリストにキューを追加します。

問題

エージェントのステータスが正しく報告されません。

原因

コネクタ構成の [状態コードが正しくない場合、エージェントのステータスが正しく表示されないことがあります。

ソリューション

確認コネクタ構成の [状態コード。

問題

WFM ソフトウェアは、コネクタに接続できません。

原因

WFM ソフトウェアは、いくつかの理由のために接続できない可能性があります。

  • コネクタが実行されていません。
  • ファイアウォールが接続をブロックします。
  • コネクタ構成の [ベンダー既定ポートのポート番号が正しくありません。

ソリューション

  • コネクタが実行されていることを確認します。
  • ファイアウォールの設定を確認します。
  • コネクタ構成の仕入先の既定のポートの構成を確認します。